Installing Virtualmin 6 KeyでERRORが発生する場合の解決方法

シェアする

Voiced by Amazon Polly

Virtualminの導入中、Installing Virtualmin 6 Keyで[ERROR] Something went wrong with the previous command. Exitingが表示される場合の解決方法について。

広告



ログを見る

/root/virtualmin-install.logを確認し、詳細を確認する。
ログには、次の内容が記載されていた。

E: gnupg, gnupg2 and gnupg1 do not seem to be installed, but one of them is required for this operation

GNUpgがインストールされていないため、リポジトリのGNUpgキーを登録できずにエラーを吐き出していた。

GNUpgをインストール

apt-get install gnupg2などのコマンドを使用して、gnupgをインストールする。
よく似たパッケージのgnubgは違うので、注意すること。
インストール後、Virtualminの導入をやり直すことができる。

次のメッセージが表示された場合は、そのままyを入力することでVirtualminのインストールをやり直すことができる。

WARNING

Virtualmin may already be installed. This can happen if an installation failed,
and can be ignored in that case.

But, if Virtualmin has already successfully installed you should not run this
script again! It will cause breakage to your existing configuration.

Updates and upgrades can be performed from within Virtualmin. To change
license details, use the ‘virtualmin change-license’ command.

Changing the license never requires re-installation.

Really Continue? (y/n)